Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
qtp 11 , win 7 , IE 8
#1
Solved: 2 Years, 11 Months, 2 Weeks, 5 Days, 10 Hours, 55 Minutes, 4 Seconds ago
hi i am on win 7 OS running qtp 11 trial 1 version with IE 8 .

My issue is while recording only window objects are recognized but no web objects are being recorded .Please guide .

varun
varun27librian@gmail.com
Reply
#2
Solved: 2 Years, 11 Months, 2 Weeks, 5 Days, 10 Hours, 55 Minutes, 4 Seconds ago
Hi Varun,

This is a very frequent question asked. Make sure you have taken care of following things,

You should

> open QTP first, other applications (Browser) next

> associate Web Add-in, though its default some time we unintentionally untick the option.

Hope this helps.
Happy Testing
Prabhat
Reply
#3
Solved: 2 Years, 11 Months, 2 Weeks, 5 Days, 10 Hours, 55 Minutes, 4 Seconds ago
nopes this dint help , first i open qtp wid all default add ins checked ..then i record but same result as always
Reply
#4
Solved: 2 Years, 11 Months, 2 Weeks, 5 Days, 10 Hours, 55 Minutes, 4 Seconds ago
Hi,
there are 2 things that you can try:
1. Right Click and run QTP as an Administrator and then try recording or recognizing objects.
2. Open QTP, go to Record and Run Settings and navigate to the Web tab and change the settings from a specific browser settings to 'Record on any open browser' setting and then try recording or recognizing objects.

Hope this helps.

Thanks
MV
Reply
#5
Solved: 2 Years, 11 Months, 2 Weeks, 5 Days, 10 Hours, 55 Minutes, 4 Seconds ago
Dear MV

it worked , koool . any specific reason why running as an admin works ,???
Reply
#6
Solved: 2 Years, 11 Months, 2 Weeks, 5 Days, 10 Hours, 55 Minutes, 4 Seconds ago
Hi Varun,
If you look at QTP requirements, it states that for QTP to successfully work on any environment, it needs to have admin level privileges to some of its files/registry options to perform its functionality. Since Windows 7 has bought in levels of security, your User ID on your test PC might NOT have had all the admin level privileges. Hence right click and running as an admin fixed your issue. Also to avoid the hassle of always having to right click and run it as an admin, just do a one time setting by right clicking on QTP desktop shortcut and select Properties. Navigate to Compatibility Tab and check the option Run as Administrator. If you want this setting to be retained for all the users that might use that PC, Click on the Button that says for all Users and do the same.

Hope this helps.
Thanks
MV
Reply
#7
Solved: 2 Years, 11 Months, 2 Weeks, 5 Days, 10 Hours, 55 Minutes, 4 Seconds ago
Thanks...Cooolll post. This discussion helped me resolving my issue...
Reply
#8
Solved: 2 Years, 11 Months, 2 Weeks, 5 Days, 10 Hours, 55 Minutes, 4 Seconds ago
Hello,

Just today i installed QTP 11, on Window 7 IE 8.

Though launching QTP as admin, Web objects were not recognized.


How to get this resolved. Let me know.


Regards,
Geethika
Reply
#9
Solved: 2 Years, 11 Months, 2 Weeks, 5 Days, 10 Hours, 55 Minutes, 4 Seconds ago
Disable User Account Control (UAC).
Navigate to Control Panel\User Accounts and Family Safety\User Accounts and change the setting to never notify.
That should help you

Regards,
Ravi
Reply
#10
Solved: 2 Years, 11 Months, 2 Weeks, 5 Days, 10 Hours, 55 Minutes, 4 Seconds ago
beacause of addins
Thanks and Regards
  Thomas Vinod
(+917799059289)
Software Test Engineer
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Qtp 10.0 Not able to identify objects on Win 8.1 64 bit OS hpuser 1 607 06-11-2015, 06:43 PM
Last Post: venkatesh9032
  Win object instead of combobox excellentpawan123 1 985 07-15-2014, 10:29 AM
Last Post: excellentpawan123
  UFT object Identification Issues with Win 8 and IE 10 Browser rajeshnunna 1 2,065 11-21-2013, 07:34 PM
Last Post: rajeshnunna
  QTP 11, Win 7 - Issue while saving the Excel through the script.bu fine in XP sivasuman 0 940 11-15-2013, 01:38 PM
Last Post: sivasuman
  QTP 11 - Chrome 24. Dialog box is identifying as Win object. Kannan R 0 1,480 08-13-2013, 08:10 PM
Last Post: Kannan R



Users browsing this thread: 1 Guest(s)